StuffIt for Mac - Minimum System Requirements

Which Apple Mac system requirements do you need for StuffIt 2011 and older versions?


StuffIt 2011 for Mac - System Requirements

Supported MAC Operating Systems

  • Mac OS X 10.5 or higher
  • MacFuse Plug-in requires MacFuse to be installed (separate download)
  • Growl support requires Growl to be installed (separate download)


StuffIt 2010 for Mac - System Requirements

Supported MAC Operating Systems

  • Mac OS X 10.4 Tiger is required for basic functionality
  • Mac OS X 10.5 or higher is required for Quicklook & MacFuse Plugins
  • Includes support for 10.6 Snow Leopard
  • Growl notification support requires Growl to be installed


StuffIt 2009 for Mac - System Requirements

Supported MAC Operating Systems

  • Mac OS X 10.4 is required for basic functionality
  • Mac OS X 10.5 "Leopard" or higher is required for Quicklook & MacFuse Plugins

Note: If you are running an older Mac OS, please visit Smith Micro Store to download one of the old StuffIt versions:
  • For Mac OS X 10.3.0 - 10.3.9 you can download StuffIt 10
  • For Mac OS X 10.1.5 - 10.2.8 you can download StuffIt 8
  • For Mac Classic you can download StuffIt 7



Download StuffIt 2011 for Mac






StuffIt for Mac is the Number 1 software compressor
30-Day Money-Back Guarantee!
30 Day money-back guarantee
There are no worries with the StuffIt
"no-questions-asked" return policy!
Instant Download
or
Worldwide Delivery / Shipping



Pay in your local currency!
Select currency in the shopping cart.


Accepted Payments
Credit card logos
Check, Money order, & Bank Transfer